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Appendix B
Quartus Il Tutorial
(Quartus Il 13.0 sp1)

This tutorial is based on Quartus Il 13.0 sp1 Web Edition (free at www.altera.com). The circuit used in the tutorial is the
registered multiplexer of figure 1a, with the VHDL code of figure 1b.

1
2 LIBRARY ieee;
3 USE ieee.std_logic_1164.all;
4
5 [HENTITY reg_mux IS
& [  PORT |
7 a, b, o, d: IN 5 0GIC VECTOR (3 DOWNTO 0} :
registered multiplexer b sel: IN STD _LC * DOWNTC O} ;
9 clk: IN =
. 10 | y: OUT STD L 0)):
a(3'0) 11 —END ENTITY;
b(3:0) 12
d q p=—Y(3:0) 13 [JARCHITECTURE reg mux OF reg mux IS
C(3:0) X(3:0) 14 L sIGNAL x: STD LOGIC VECTOR(3 DOWNIO 0):
d(3:0) 15 [EBEGIN
16 X <= a WHEN sel="00" ELSE
17 b WHEN sel="01" ELSE
sel(1:0) clk 18 c WHEN sel="10" ELSE
i3 d;
20 = FROCESS (clk
@ (b) = fetk)
21 | BEGIN
22 =] IF rising_ edge (clk) THEN
Figure 1 = Vo=
24 B END IF;
25 B END PRCOCESS;
26 —END ARCHITECTURE;
27

1. Starting a New Project

a) Launch Quartus Il, which opens the screen of figure 2. Click Create a New Project, which leads to figure 3.
Note: If Quartus Il is already open, do File > New Project Wizard to get the screen of figure 3.

b) Set the design location and name (see figure 3):

- Enter the name of the directory where all project files should be located (reg_mux, in this tutorial). If the directory does
not exist yet, just type in the desired name (with the proper path) and Quartus Il will create it for you.

- Enter the project’s name (preferably, use the same name for the directory, for the project, and for the entity).

- Note that the entity’s name is filled in automatically.

Click Finish until the Project Navigator (figure 4a) is displayed.

c) Enter the VHDL code of figure 1b. To do so, open the VHDL editor by clicking O or by selecting File > New, which
prompts the list to figure 4b. Select VHDL File and click OK. After typing the VHDL code, save it as reg_mux.vhd.
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2. Synthesizing the Design

a) Define the device in which the circuit should be implemented by selecting Assignments > Device. In the Family field,
select Cyclone Ill. In the Target Device field, mark Specific device selected in ‘Available devices’ list and select
EP3C16F484C6 (FPGA of the DEO board).

b) Compile the code by clicking ™ or by selecting Processing > Start Compilation.

Note: For a faster compilation, particularly useful while the VHDL code is still being debugged, click "57 or select
Processing > Start > Start Analysis and Synthesis. In this case, no timing information is recorded. After the code is working

properly, full compilation ( ™) should then be performed.

¢) When the compilation ends, the Compilation Report of figure 5 is exhibited, which contains several pieces of valuable
information, some of which are described in the next section.

| \iﬁf! reg_mux.vhd Q Compilation Report - reg_mux @
Table of Contents og mmary
2 Flow Summary Flow Status Successful - Sat Nov 30 17:36:33 2013
=1 Flow Settings Quartus II 64-Bit Version 13.0.1Build 232 06/12/2013 5P 151 Web Edition
Revision Name reg_mux
E= Flow Non-Default Global Settings Top-evel Entity Name o
= Flow Elapsed Time Family Cydlone IIT
EH Flow 05 Summary Device EP3C16F484CE
] Flow Log Timing Models Final
> ] Analysis & Synthesis Total logic elements 8/15408 (< 1%)
. Total combinational functions 8/15408(<1%)
’ _—I Fitter Dedicated logic registers 415408 (< 1%)
" Flow Messages Total registers 4
(1) Flow Suppressed Messages Total pins 23/347(7%)
> |1 Assembler Total virtual pins 1]
> [[J TimeQuest Timing Analyzer Total memory bits 0/515,095 (0 %)
Embedded Multiplier 9-bit elements 0/ 112(0 %)
Figure 5 Total PLLs 0/4(0%)

3. Inspecting Synthesis Results
This section describes some of the results produced by the compiler.

a) Device type and number of pins: Check in figure 5 if the device type is the intended one (Cyclone Il EP3C16F484C6).
Check also if the total number of pins is as expected (4x4+2+1= 19 inputs + 4 outputs = 23 pins).

b) Number of logic elements: Figure 5 shows also the amount of logic needed to implement the circuit. In this case, 8 logic
elements were needed, out of 15,408 LEs available in that device.

c) Number of registers: Since y is a 4-bit signal (figure 1a), 4 flip-flops are expected to be inferred by the synthesizer. This
also can be checked in figure 5, which shows a total of 4 registers.

d) RTL View: This tool shows how the code was interpreted by the compiler (before optimization and fitting). Select Tools
> Netlist Viewers > RTL Viewer, which exhibits the circuit of figure 6 (or equivalent). Because 2-input multiplexers are
available in the device, a total of 3 units were used to implement the 4-input mux (the other three blocks at the input are
for processing sel). Note also the 4-bit register (4 D-type flip-flops —DFFs) at the output.

= ol Figure 6
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e) Equations: They represent the actual circuit implemented by the compiler. In the Compilation Report, select Fitter >
Equations (if this option is not available, go to Tools > Options > General > Processing and mark Automatically generate
equation files during compilation, then recompile the code). To interpret the equations, see first section 7. For example,
“A1L41Q = DFFEAS(A1L60, GLOBAL(A1L2),...);” means that the output of cell A1L41Q is produced by a DFF whose data
input comes from cell A1L60 and whose clock input is fed by a global signal from cell A1L2. Confirm in the equations that
the total number of DFFs is indeed 4.

f) Timing analysis: In the Compilation Report, select TimeQuest Timing Analyzer > Slow 1200mv 85C Model > Worst-Case
Timing Paths and check the minimum clock pulse width.

g) Pin assignments: This will be treated in section 5.

4. Simulating the Circuit

a) To perform manual graphical simulation (which is the only kind supported by Quartus 1), we must first draw the input

waveforms, based on which the simulator will calculate and plot the output waveform. Click O or select File > New, which
will prompt again the list of figure 4b.

b) Select Verification/Debugging Files > University Program VWF and click OK. This opens the wave pane of figure 7.
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Figure 7
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¢) The time axis in figure 7 goes from 0 to 1 us. If a different end time is needed, select Edit > Set End Time and enter the
desired value.

d) The grid can also be adjusted as needed by selecting Edit > Grid Size. Keep the default value (10 ns).

e) Now add signals to the waveform editor. Press the right mouse button in the white area under Name (in figure 7) and
select Insert > Insert Node or Bus, which leads to figure 8a.
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e e - =
N a[g] Input E
Bom et
Bus width: 1 '§ b Input Group -
-<
in_ p[o] Input
Startindex: 0 >
D % bl1] Input
" b2 Input
(a) " b[3] Input
i§ [4 Input Group
in_ cfo] Input
Figure 8 (b) | el Input M
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(f) Click Node Finder, which opens the screen of figure 8b (but empty). In the Filter field, select Pins: all & Registers: post-
fitting (a simpler option is Pins: all), then click List. The left column will be filled with the signals (partially) shown in figure

8b. Click on the desired signals to select them and pass them to the column on the right by clicking A Click OK twice,
which will fill the waveforms window with the signals of figure 9.

g) To change the position (order) of a signal in figure 9, click on its name to select it, then click again and hold the mouse
button, dragging next the signal to the desired position. Do as in figure 9, with all inputs first and the clock at the top.

h) Before drawing the waveforms, set the desired representation radix.

- Click the left mouse button on clk (figure 9) to select it, then click the right mouse button and select Radix > Binary.

- Click the left mouse button on a, b, ¢, d, sel, and y to select them, then click the right mouse button and select Radix >
Unsigned Decimal.

£, Simulstion Waveform Editor - Ci/Altera/13.0.1.232/quartus_designs/reg_mux/reg_mux - reg_mux - [reg_musvwf] o | Eli.
Fle Edit View Smulaion Help 5) Search altera.cam ]
D 2 0 Z)E0E B EE TR 2824 [FH
Master Time Bar: 0 ps E] E] Pointer: 0 ps Interval: 0ps Start: End:
0ps 80.0ns 160.0ns 240.0ns 320.0ns 400.0ns 430.0ns 560.0ns 640.0ns 720.0ns 800.0ns 880.0ns g60.0ns  *
Name b i i i i i i i i i i i
ps
nodk
B b a [}
[N [}
i b [}
i b [}
By b osel )
" X
Figure 9
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i) Now we must draw the input waveforms (clk, a, b, c, d, sel), after which the simulator will compute and draw the output
waveform (y). The stimuli of figure 10 are adopted.

- Click on clk to select it. Click then the clock icon A& and enter 80 ns for the period and O for the offset.

- Click on a to select it. Then click the arbitrary value icon #2 and enter 2. Now select line a only from 80 ns up and enter 3
ns, using again the arbitrary value icon.

- Repeat the process above for b, ¢, and d, entering the values shown in figure 10.

- Click on sel to highlight it. Then click the counter icon X€ and enter Start value = 0, Increment = 1, Count type = Binary,
and Count every = 160 ns.

j) Save the file with the same name as the entity’s name and extension .vwf (vector waveform file), that is, reg_mux.vwf.
Recall that the last waveform (y) will be filled by the simulator.

€4 Simulation Waveform Editor - [reg_munesim.vwf (Read-Only]] =RACE X
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k) Choose the simulator in Simulation > Options (ModelSim or Quartus Il Simulator).

I) Run the simulation:
A=
- For functional simulation, click ¥n or select Simulation > Run Functional Simulation.

5
- For timing simulation, click ®n or select Simulation > Run Timing Simulation.

m) Inspect the results (compare them to those in figure 10).

5. Making Pin Assignments

Case 1: Manual pin assignments

_|>_r|
a) Select Assignments > Pin Planner or click ‘-«I"' which opens the window of figure 11.
b) In the Location column, enter the desired pin numbers.
c) Recompile the code.

Note: Assignments can be deleted with Assignments > Remove Assignments.

{%# Pin Planner - C/Altera/13.0.1.232/quartus_designs/reg_mux/reg_mux - reg_mux = | B ki)
File Edit View Frocessng Tools Window Help 5 Search altera.com @
—, | Report 1@ x Top View - Wire Bond

Report not available
=Y
i == ==
5] Groups Report
a aTaTarol \/8
- = 3 al ==
s HEI% : OSOOOANADE00 -
5 OOOSANT,

B Run Analysis and E 4 : coine SREAXEYS

[E . . |j M 0%0 VOOV, %@ -

4 | EarlyPin Planning | 24000000000 0DRO0
= < = DEO0SOEE0SOOAY
" 1 Eaelu Dim Blarmi : : e
=«

ﬂﬁ x| Named: * - Edit: v | |Filber:[Pins: all -
= g Mode Name Direction Location 1/0 Bank VREF Group Fitter Location I/0 Standard e
Bl n_ a[3] Input | PIN_M4 2.5V (default)
- n_ a[2] Input PIN_V1 2,5V {default)
& |narg Input PIN_¥2 2.5V (default)
g n_ afo] Input PIN_AA1 2,5V {default)
n_ b[3] Input PIN_M1 2.5V (default) =
) n_ b[2] Input PIN_R2 2,5V {default)
- in_ b1 Input PIN_M3 2.5V (default)
"” in_ blo] Input PIN_M2 2.5V (default)
21 lin_ o3 Tnput PIN_V2 2.5V (default)
B n_ 2] Input PIN_U2 2,5V {default) L
in_ 1] Tnput PIN_L7 2.5V (default)
1. o] Input PIN_MS 2,5V {default)
L Tnput PIN_G2 2.5V (default)
n_ d[3] Input - PIN_P2 2,5V {default)
i drz] Tnput Figure 11 PIN_P4 2.5V (default)
£ diy Input PIN_P& 2.5V (default) -
=4[ 1 | b
Early Pin Planning 0% 00:00:00

Case 2: Importing pin assignments with a CSV file

Pin assignments can be imported and exported using CSV (comma separated value) files. The initial pin assighments, made
automatically by the compiler, cannot be exported.

a) Select Assignments > Import Assignments and choose the corresponding .csv file.
b) Recompile the code.

Note: To export a pin assignment, select Assignments > Pin Planner, then File > Export.
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6. Downloading the Design to the FPGA

a) Connect the FPGA board to an USB port of your computer and turn the board’s power on.
Note: If this is the first time that you are using a board that interfaces using an USB port, the USB-Blaster Driver must be
installed (generally done automatically).

b) In Quartus Il, click the Programmer icon w or select Tools > Programmer, which opens the window of figure 12. Note
the following:

- The hardware driver is USB-Blaster.

- The mode is JTAG.

- The programmer file is reg_mux.sof.

- The Program/Configure box is checked.

c) Click Start, and the device will be programmed. Observe what happens to the board’s LEDs during programming.

w Programmer - Ci/Altera/13.0.1.232/quartus_designs/reg_mux/reg_mux - reg_mux - [output_files/reg_mux.cdf] E@éj

Fie Edit View Processing Tools Window Hep 57 Search altera.com @
£, Hardware Setup....| USB-Blaster [USB-0] Mode: Progress: :
[] Enable real-time 15P to allow background programming (for MAX II and MAX V devices)
W File Device Checksum Usercode Program/ Verify Blank-
Confiure check
b stop output_filesfreg_mux.sof  EP3C16F484 000C9838 000C9838
it Sty
3 Auto Detect
Delete
] 1l +
[ Add File...
-
1% Change File...
Save File
- TDI —"
|4 Add Device... — 3 | p 5
Thup
T Dawn EP3C16F484 . LA
, o Figure 12
4

7. Interpreting the Fitter Equations
Below are the main symbols used in the Fitter equations.
a) Logic operators: | (NOT), & (AND), # (OR), S (XOR)

b) Flip-flops:

DFF (D, CLK, CLRN, PRN) (DFF with reset and preset, both active low)

DFFE (D, CLK, CLRN, PRN, ENA) (DFF above plus enable)

DFFEA (D, CLK, CLRN, PRN, ENA, ADATA, ALOAD) (DFF above plus asynchronous data load)
DFFEAS (D, CLK, CLRN, PRN, ENA, ADATA, ALOAD) (DFF above with synchronous clear)
TFFE (T, CLK, CLRN, PRN, ENA) (TFF with reset, preset, and enable)

Note: Recall that in the context of this book/course a reset signal is called reset when it is asynchronous and it is called
clear when it is synchronous.



